babai/flake.nix
2025-01-29 17:50:44 -07:00

30 lines
686 B
Nix

{
description = "Simple flutter and dart flake";
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
inputs.flake-utils.url = "github:numtide/flake-utils";
outputs = {
flake-utils,
nixpkgs,
...
}:
flake-utils.lib.eachDefaultSystem (system: let
pkgs = import nixpkgs {
inherit system;
};
in {
devShell = pkgs.mkShell {
buildInputs = with pkgs; [
flutter
dart
];
enterShell = ''
echo "Welcome to Bab.ai development environment"
'';
shellHook = ''
export PATH="$PATH":"$HOME/.pub-cache/bin"
'';
};
});
}